之前的php5.3,不知道被我改了什么东西,错误一堆(如修改disable_functions无效、display_error off之后还能显示错误信息等……)于是便打算修复一下= =

尝试过重装php5.3,发现居然提示Not replacing deleted config file /etc/php5/fpm/php.ini,奇葩- -

然后我就想到升级到php5.4试试。。。

在/etc/apt/sources.list添加

然后

然后

提示

应该是之前的php没有卸载完全吧,搜了下,原来要卸载配置文件需要加--purge参数

OK,一切顺利。

安装完后PHP版本为

5.4.13-1~dotdeb.1

至于跟php5.3有什么不同,我倒是没感觉出来= =只不过前面提到的错误全部修复了

   

已有 13 條評論

  1. 爱奇趣分享网 4 年前 (2015-08-21)
    @

    爱奇趣网http://www.iqiqu.net/? 路过留个言!

  2. 电脑爱好者之家 7 年前 (2013-04-15)
    @

    我的还是5.2版本 不敢升级 死了就完了 还要重装系统…

  3. VPNYou 7 年前 (2013-04-03)
    @

    发现你竟然申请了我的主机,你不也是IDC么,哇咔咔?顺便打个广告:奇奇主机[client.qiqizone.com]五折优惠码:GreedIsGood

    • 飛天鼠 7 年前 (2013-04-03)
      @

      有问题咩。。。。。

      • VPNYou 7 年前 (2013-04-03)
        @

        为嘛回复这么快

        • 飛天鼠 7 年前 (2013-04-03)
          @

          桌面提醒。。。。

          • VPNYou 7 年前 (2013-04-03)
            @

            我发现我也有

          • vfhky 6 年前 (2013-07-24)
            @

            糕富帅啊,vps折腾不起

  4. 夏宇轩网赚 7 年前 (2013-04-02)
    @

    我也来转转,收获还不少

  5. 阿福 7 年前 (2013-04-02)
    @

    地板

  6. Yu Jing 7 年前 (2013-04-01)
    @

    yum update -y永远更新

  7. 大笨马优惠码 7 年前 (2013-03-30)
    @

    沙发